OpenRoads Designer CONNECT Edition SDK Help

Spiral Properties

Properties

Constant Gets geometric constant that defines the spiral
Deflection Gets deflection
DeltaR Gets spiral DeltaR
Direction Gets spiral direction at the start point
EndArcCenterPoint Gets the arc center point of the end point |
EndRadius Gets spiral end radius
Hand Gets spiral hand
IntrinsicPoint Gets the spiral intrinsic point
IsOutgoing Gets whether the spiral is going
IsSimple Gets whether the spiral is simple
KValue Gets K value
LongChord Gets long chord
LongTangent Gets long tangent
PValue Gets P value
ShortTangent Gets short tangent
SpiralType Gets spiral type
StartArcCenterPoint Gets the arc center point of the start point |
StartDirection Gets spiral start direction at start point
StartRadius Gets spiral start radius
SweepAngle Gets sweep angle
Xs Gets the end point Xs value from the start point(not from intrinsic point)
Ys  

See Also